Tuesday, 06 December 2011 07:13

Upgrade to Exchange Server 2010 SP2

Written by

The SP2 upgrade is almost straight forward from Exchange 2010 SP1; however it requires the IIS 6 WMI Compatibility component for CAS role upgrade. Normally this would be installed when initially you have added Web Server (IIS) role, if this component is not installed already then add it prior installing SP2.

Follow the simple steps below(I did upgrade from my Exchaneg 2010 SP1 installation).

  1. Install ‘IIS 6 WMI Compatibility’ if not installed already,
    1. Open Server Manager
    2. Expand Roles and right click on Web Server (IIS) and click on Add Role Services
    3. Select ‘IIS 6 WMI Compatibility’ under IIS6 Management Tool-> IIS6 Management Compatibility
  2. Extract the SP2 files, and click on Setup
  3. Continue the installation wizard (see if you receive any other errors/warning at Readiness check)
  4. Click on Upgrade and wait for the installation to finish.

The upgrade will almost take the same time as the installation, hence wait until the process completes. The installation did not give any other issues, and went just fine.

You can see that the Version is 14.2 and the Build is 247.5

Exchange_2010_SP2_Version_and_Build-new

Note - This will just the istallation wizard update, I recomend to do the required infrastructure testing prior to upgrading your production servers.

Share you experience during the installations, to ease the process for others.

-Praveen

theme by reviewshub